码迷,mamicode.com
首页 > 其他好文 > 详细

uva 674 Coin Change (DP)

时间:2015-03-11 19:43:09      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:acm   c语言   

uva 674 Coin Change

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input
The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11
26

Sample Output

4
13

题目大意:有5种硬币:1分,5分,10分,25分,50分。给出总钱数N,要求出用着5种硬币,有多少种组成方式。

解题思路:递推。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int dp[8000], coin[5] = {1, 5, 10, 25, 50};
int main() {
    int n;
    while (scanf("%d", &n) != EOF) {
        memset(dp, 0, sizeof(dp));
        dp[0] = 1;
        for (int i = 0; i < 5; i++) {
            for (int j = coin[i]; j <= n; j++) {
                if (dp[j - coin[i]]) {
                    dp[j] += dp[j - coin[i]];
                }
            }
        }
        printf("%d\n", dp[n]);
    }
    return 0;
}

uva 674 Coin Change (DP)

标签:acm   c语言   

原文地址:http://blog.csdn.net/llx523113241/article/details/44202291

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!