码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1492 The number of divisors(约数) about Humble Numbers 数论~~

时间:2015-03-12 17:17:24      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:hdu1492   the number of diviso   数论   

The number of divisors(约数) about Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2781    Accepted Submission(s): 1354


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

 

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
 

Output
For each test case, output its divisor number, one line per case.
 

Sample Input
4 12 0
 

Sample Output
3 6
 

Author
lcy
 
看博客吧~~我数学不行~~
http://blog.csdn.net/chengouxuan/article/details/6880804

我的代码:
#include <stdio.h>
typedef long long ll ;

ll div(ll n, int fac)
{
	ll ans = 0 ;
	while(n%fac==0)
	{
		++ans ;
		n /= fac ;
	}
	return ans ;
}

int main()
{
	ll n ;
	while(~scanf("%I64d",&n) && n)
	{
		ll ans = 1;
		ans *= div(n,2)+1;
		ans *= div(n,3)+1;
		ans *= div(n,5)+1;
		ans *= div(n,7)+1;
		printf("%I64d\n",ans) ;
	}
	return 0 ;
}

与君共勉

hdu 1492 The number of divisors(约数) about Humble Numbers 数论~~

标签:hdu1492   the number of diviso   数论   

原文地址:http://blog.csdn.net/lionel_d/article/details/44222479

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!