码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1308 Is It A Tree? 并查集

时间:2015-03-12 17:22:15      阅读:107      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
技术分享

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
//思路  没有孤立的节点 没有环就是树
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=99999;
int a[maxn];//并查集
int rank[maxn];//树高

void init()
{
    for(int i=0;i<maxn;i++)a[i]=i,rank[i]=0;
}

int find(int x)
{
    if(x==a[x])return x;
    return a[x]=find(a[x]);
}

void unit(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y)return ;
    if(rank[x]<rank[y])
        a[x]=y;
    else
    {
        a[y]=x;
        if(rank[x]==rank[y])rank[x]++;
    }
}

bool same(int x,int y)
{
    return find(x)==find(y);
}
bool vis[maxn];
int main()
{
    int n,m,i,j,k,t;
    int x,y;int cas=1;
    while(true)
    {
        init();
        int ok=0;//判断是否存在环
        memset(vis,false,sizeof(vis));
        while(cin>>x>>y)
        {
            if(x==-1&&y==-1)return 0;
            if(!x&&!y)break;
            vis[x]=vis[y]=true;
           if(!same(x,y))
                unit(x,y);
           else ok=1;
        }
        int sum=0;
        for(i=1;i<maxn;i++)if(vis[i])
        {
            if(i==a[i])sum++;//判断是否存在孤立的节点
        }
        if(ok||sum>1)printf("Case %d is not a tree.\n",cas++);
        else printf("Case %d is a tree.\n",cas++);

    }

    return 0;
}




POJ 1308 Is It A Tree? 并查集

标签:

原文地址:http://blog.csdn.net/u013167299/article/details/44222213

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!