码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2456 Aggressive cows 二分

时间:2015-03-12 19:20:32      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

  • Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

题目大意

有N间小屋,第i个小屋在xi的位置。要让人尽可能远离其他人,问最大能安排多大的距离

解题思路

二分查找可行解
记住二分的模板,就以这题的二分为标准

代码

//POJ2456
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int s[maxn];
int n,m;
bool ok(int x)
{
    int cnt = 1;
    int tmp = s[0];
    for(int i = 1 ; i < n ; i ++) {
        if(s[i]-tmp >= x) {
            cnt ++;
            tmp = s[i];
        }
    }
    return cnt >= m;
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i = 0 ; i < n ; i ++) scanf("%d",&s[i]);
    sort(s,s+n);
    int ma = s[n-1]-s[0],mi = 0;
    while(ma > mi) {
        int mid = mi + (ma-mi+1)/2;
        if(ok(mid)) mi = mid;
        else ma = mid-1;
    }
    printf("%d\n",mi);
    return 0;
}

POJ2456 Aggressive cows 二分

标签:

原文地址:http://blog.csdn.net/area_52/article/details/44224633

(0)
(1)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!