码迷,mamicode.com
首页 > 其他好文 > 详细

(hdu 简单题 128道)hdu 1194 Beat the Spread!(已知两个数的和u两个数的差求这两个数)

时间:2015-03-12 20:56:37      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:

题目:

Beat the Spread!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5169    Accepted Submission(s): 2692


Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?
 

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
 

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
 

Sample Input
2 40 20 20 40
 

Sample Output
30 10 impossible
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:  1163 1201 1164 1205 1152 


题目分析:

               已知a+b和a-b求a、b。


代码如下:

/*
 * b.cpp
 *
 *  Created on: 2015年3月12日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>

using namespace std;


int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int sum;
		int diff;
		scanf("%d%d",&sum,&diff);

		if(sum < diff){//如果两个数的和<两个数的差
			printf("impossible\n");//不可能有结果(a,b均>=0)
		}else if((sum+diff)%2 != 0){//如果(a+b) + (a-b) 不是偶数
			printf("impossible\n");//不可能
		}else{//否则符合正常逻辑
			printf("%d %d\n",(sum+diff)/2,(sum-diff)/2);//计算这两个数都是什么
		}
	}

	return 0;
}





(hdu 简单题 128道)hdu 1194 Beat the Spread!(已知两个数的和u两个数的差求这两个数)

标签:

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/44225867

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!