码迷,mamicode.com
首页 > 其他好文 > 详细

(状态压缩dp) poj 3254

时间:2015-03-13 09:18:46      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:

Corn Fields
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8729   Accepted: 4651

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can‘t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source

 
注意读入的时候 ,要将读入的0,1置换。防止多余的重复
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define maxn 10010
#define MOD 100000000
int n,m,a[15],dp[15][maxn],sta[maxn];
bool judge(int x,int y)
{
    if(x&y) return false;
    return true;
}
void fun()
{
    int num=0;
    int sum=(1<<m);
    for(int i=0;i<sum;i++)
    {
        if(i&(i<<1))
            continue;
        sta[num++]=i;
    }
    for(int i=0;i<num;i++)
    {
        if(judge(a[1],sta[i]))
        {
            dp[1][i]=1;
        }
    }
    for(int i=2;i<=n;i++)
    {
        for(int j=0;j<num;j++)
        {
            if(!judge(a[i],sta[j]))
                continue;
            for(int k=0;k<num;k++)
            {
                if(!judge(sta[k],a[i-1]))
                    continue;
                if(!judge(sta[k],sta[j]))
                    continue;
                dp[i][j]=(dp[i][j]+dp[i-1][k])%MOD;
            }
        }
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        int x,ans=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%d",&x);
                if(x==0)
                   a[i]+=(1<<(m-j));
            }
        }
        fun();
        for(int i=0;i<(1<<m);i++)
            ans=(ans+dp[n][i])%MOD;
        printf("%d\n",ans);
    }
    return 0;
}

  

(状态压缩dp) poj 3254

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4334235.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!