码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2161 Primes 筛法求素数 大水题

时间:2015-03-13 14:24:56      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:hdu2161   primes   数论   水题   

Primes

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7659    Accepted Submission(s): 3130


Problem Description
Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.
 

Input
Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.
 

Output
The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no".
 

Sample Input
1 2 3 4 5 17 0
 

Sample Output
1: no 2: no 3: yes 4: no 5: yes 6: yes
 没什么好说的
代码:
#include <stdio.h>
#define MAX 16100
bool notPrime[MAX] ;
int main()
{
	for(int i = 2 ; i < MAX ; ++i)
	{
		for(int j = 2 ;j*i < MAX ; ++j)
		{
			notPrime[i*j] = true ;
		}
	}
	notPrime[1] = notPrime[2] = true ;
	int n , c=1;
	while(~scanf("%d",&n) && n>0)
	{
		printf("%d: ",c++) ;
		if(!notPrime[n])
		{
			puts("yes");
		}
		else
		{
			puts("no") ;
		}
	}
	return 0;
}

与君共勉

hdu 2161 Primes 筛法求素数 大水题

标签:hdu2161   primes   数论   水题   

原文地址:http://blog.csdn.net/lionel_d/article/details/44240273

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!