码迷,mamicode.com
首页 > 其他好文 > 详细

【POJ 1160】Post Office

时间:2015-03-13 16:37:26      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:bzoj   oi   dp   四边形不等式优化   

Post Office
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 16454   Accepted: 8915

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

Source



四边形不等式优化dp。


先说朴素的dp方程:

f[i][j]表示前j个村庄建i个邮局的最小代价。 

w[i][j]表示i到j之间建一个邮局的最小代价(显然是建在中间代价最小)

f[i][j]=min(f[i-1][k]+w[k+1][j])


这样转移是O(n^3)的。


四边形不等式优化dp赵爽论文


四边形不等式优化的大致流程是:

如果w[i][j]满足四边形不等式即w[i][j]+w[i‘][j‘]<=w[i][j‘]+w[i‘][j]  (i<=i‘<=j<=j‘),


那么f[i][j]也满足四边形不等式,


设f[i][j]=f[i-1][k]+w[k+1][j],f[i][j]在k的时候取到最优值,记s[i][j]=k,则s[i][j]满足单调性:

s[i-1][j]<=s[i][j]<=s[i][j+1]


于是k就不需要从1开始枚举了,从s[i-1][j]到s[i][j+1]枚举即可。


这里有详细证明。


一般证明dp方程满足四边形不等式比较复杂,因此我们只要把s[i][j]暴力求出,看是否满足s[i-1][j]<=s[i][j]<=s[i][j+1]即可。


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
int w[305][305],f[305][305],s[305][305],n,m,p[305];
void Getw()
{
	for (int i=1;i<=n;i++)
	{
		w[i][i]=0;
		for (int j=i+1;j<=n;j++)
			w[i][j]=w[i][j-1]+p[j]-p[(i+j)>>1];
	}
}
int main()
{
        scanf("%d%d",&n,&m);
	for (int i=1;i<=n;i++)
		scanf("%d",&p[i]);
	Getw();
	memset(f,127,sizeof(f));
	for (int i=1;i<=n;i++)
		f[1][i]=w[1][i],s[1][i]=0;
	for (int i=2;i<=m;i++)
	{
		s[i][n+1]=n;
		for (int j=n;j>=i;j--)
			for (int k=s[i-1][j];k<=s[i][j+1];k++)
				if (f[i-1][k]+w[k+1][j]<f[i][j])
					s[i][j]=k,f[i][j]=f[i-1][k]+w[k+1][j];
	}
	printf("%d\n",f[m][n]);
	return 0;
}

技术分享

【POJ 1160】Post Office

标签:bzoj   oi   dp   四边形不等式优化   

原文地址:http://blog.csdn.net/regina8023/article/details/44241817

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!