码迷,mamicode.com
首页 > 其他好文 > 详细

dp之状态压缩水题总结

时间:2015-03-13 20:21:21      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:

状态压缩dp

其实就是 将状态表示成二进制,然后用位运算进行求解

 

poj 3311

Hie with the Pie
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5080   Accepted: 2706

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

 
TSP问题
dp[状态]【i】 表示 经过i点时候的状态。1A!!!
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
using namespace std;
#define INF 0x7fffffff
#define maxn 10010
int n,dp[maxn][12],a[12][12],ans;
void floyd()
{
    for(int k=0;k<=n;k++)
    {
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
                a[i][j]=min(a[i][j],a[i][k]+a[k][j]);
        }
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
                scanf("%d",&a[i][j]);
        }
        floyd();
        for(int s=0;s<(1<<n);s++)
        {
            for(int i=1;i<=n;i++)
            {
                if(s&(1<<(i-1)))
                {
                    if(s==(1<<(i-1))) dp[s][i]=a[0][i];
                    else
                    {
                        dp[s][i]=INF;
                        for(int j=1;j<=n;j++)
                        {
                            if(i!=j&&(s&(1<<(j-1))))
                                dp[s][i]=min(dp[s][i],dp[s^(1<<(i-1))][j]+a[j][i]);
                        }
                    }
                }
            }
        }
        ans=dp[(1<<n)-1][1]+a[1][0];
        for(int i=2;i<=n;i++)
            if(ans>dp[(1<<n)-1][i]+a[i][0])
                ans=dp[(1<<n)-1][i]+a[i][0];
        printf("%d\n",ans);
    }
    return 0;
}

  

dp之状态压缩水题总结

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4335783.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!