码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 1097 - A hard puzzle (快速幂取模)

时间:2015-03-14 09:41:50      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:acm   hdu   algorithm   快速幂      

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32633    Accepted Submission(s): 11672


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b‘s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b‘s last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9 6
 

Author
eddy
 




AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int k_mi(int a, int b) {		//快速幂取模 
	int t = a % 10, ans = 1;
	while(b) {
		if(b&1) ans = (ans * t) % 10;
		t = (t * t) % 10;
		b >>= 1;
	}
	return ans % 10;
}

int main() {
	int a, b;
	while(scanf("%d %d", &a, &b) != EOF) {
		printf("%d\n", k_mi(a, b));
	}
	return 0;
} 
















HDU - 1097 - A hard puzzle (快速幂取模)

标签:acm   hdu   algorithm   快速幂      

原文地址:http://blog.csdn.net/u014355480/article/details/44247119

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!