标签:
Find The Multiple
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 19430 |
|
Accepted: 7879 |
|
Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal
digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
Source
题目描述的100位,吓了一跳,以为是大数,看别人代码才知道这个题实际上不会超过unsigned __int64,题目大意是找一个数m是n的倍数,m只由0和1组成,和样例的输出不一样也过了
ac代码
#include<stdio.h>
#include<string.h>
int n,m;
int flag;
void dfs(unsigned __int64 num,int k)
{
if(flag==1||k==19)
return;
if(num%n==0)
{
printf("%I64u\n",num);
flag=1;
return;
}
dfs(num*10,k+1);
dfs(num*10+1,k+1);
}
int main()
{
while(scanf("%d",&n)!=EOF,n)
{
flag=0;
dfs(1,0);
}
}
POJ 题目1426 Find The Multiple(DFS)
标签:
原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44260371