码迷,mamicode.com
首页 > 其他好文 > 详细

(hdu step 6.3.5)Card Game Cheater(最大匹配数:a与b打牌,问b能赢a多少次)

时间:2015-03-14 17:04:27      阅读:461      评论:0      收藏:0      [点我收藏+]

标签:

题目:

Card Game Cheater

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 103 Accepted Submission(s): 74
 
Problem Description
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit. 

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. 

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally. 

 
Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD
 
Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.

 
Sample Input
3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D
 
Sample Output
1
1
2
 
 
Source
Northwestern Europe 2004
 
Recommend
8600


题目大意:

a和b手上都有n张牌,b的一张牌赢了a的一张牌,b就得一分,问b能得多少分。

样例分析:

输入:


3
1//两个人手中的牌的张数
JD//adams手上的牌
JH//eves手上的牌
2
5D TC
4C 5H

输出:

第二个样例中的输出结果为1.为什么呢。因为eves手上只有5H比adams手上的5D大,得1分。他手上的4C要比

adams手上的TC要小,不能得分。


题目分析:

              二分图,求最大匹配。需要注意的是。

1、这道题中的匹配规则已经不是“a愿不愿意与b匹配”了,而是,只有在b>a的时候才能匹配

2、这道题中b和a都是字符串。如何比较大小呢?先比较第1个字符然后,如果第1个字符相等再比较第2个字符。

3、这道题是用的是邻接表求的最大匹配数。



代码如下:

/*
 * e.cpp
 *
 *  Created on: 2015年3月14日
 *      Author: Administrator
 */

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>

using namespace std;

const int maxn = 27;

vector<int> map[maxn];
bool useif[maxn];
int link[maxn];

int n;

/**
 * 获取一张牌前缀的索引
 */
int card_pre(char a){
	string pre = "23456789TJQKA";
	int len = pre.length();

	int i;
	for(i = 0 ; i < len ; ++i){
		if(a == pre.at(i)){
			return i;
		}
	}

	return 0;
}

/**
 * 获取一张牌后缀的索引
 */
int card_suf(char a){
	string suf = "CDSH";
	int len = suf.length();
	int i;
	for(i = 0 ; i < len ; ++i){
		if(a == suf.at(i)){
			return i;
		}
	}

	return 0;
}

/**
 * 比较a和b这两张牌哪一张牌比较大
 */
bool isBig(string a,string b){
	int aa = card_pre(a[0]);//获取一张牌的前缀
	int bb = card_pre(b[0]);//获取一张牌的后缀

	if(aa == bb){//如果这两张牌的前缀相同
		return card_suf(a[1]) < card_suf(b[1]);//则比较后缀
	}

	//如果这两张牌的前缀已经不相同则直接比较前缀
	return aa < bb;
}


/**
 * 判断一个节点t能否找到和她匹配的节点
 */
bool can(int t){
	int i;
	int size = map[t].size();//获取愿意与节点t匹配的结点的数量
	for(i = 0 ; i < size ; ++i){//遍历每一个愿意和结点t匹配的结点
		int index = map[t][i];//获取当前愿意和结点t匹配的节点的索引
		if(useif[index] == false){//如果这个节点还没有匹配
			useif[index] = true;//那么将这个节点标记为已经匹配
			//如果这个节点还没有匹配的节点||月这个节点匹配的节点能够找到其他结点与它匹配
			if(link[index] == -1 || can(link[index])){
				link[index] = t;//那么将当前节点匹配的结点设置为t

				return true;//返回true,表示根节点t能够找到与它匹配的节点
			}
		}
	}

	return false;//返回false,表示节点t无法找到与它匹配的结点
}


/**
 * 求醉大匹配数
 *
 */
int max_match(){
	int num = 0;

	int i;
	for(i = 0 ; i < n ; ++i){//遍历每一个结点
		memset(useif,false,sizeof(useif));
		if(can(i) == true){
			num++;
		}
	}

	return num;
}


int main(){
	int t;
	scanf("%d",&t);

	string adams[maxn];

	while(t--){
//		int n;//这里千万不要在定义一个局部变量,否则会覆盖全局变量
		scanf("%d",&n);
		int i;

		//初始化变量
		memset(link,-1,sizeof(link));
		for(i = 0 ; i < n ; ++i){
			map[i].clear();
		}

		for(i = 0 ; i < n ; ++i){//初始化adams的牌
			cin >> adams[i];
		}

		string eves;
		/**
		 * 每次读入eves当前的牌,都接着计算它能与adams的那些牌匹配.
		 * 这列的匹配规则已经不是:a愿不愿意 与b匹配了.
		 * 而是只有当b>a的时候,b才能与a匹配
		 * (为什么呢?因为eves要得分,那么他手上的牌就必须要比adams的大)
		 */
		for(i = 0 ; i < n ; ++i){
			cin >> eves;

			int j;
			for(j = 0 ; j < n ; ++j){
				if(isBig(adams[j],eves) == true){
					map[i].push_back(j);
				}
			}
		}

		printf("%d\n",max_match());//计算最大匹配数
	}

	return 0;
}






(hdu step 6.3.5)Card Game Cheater(最大匹配数:a与b打牌,问b能赢a多少次)

标签:

原文地址:http://blog.csdn.net/hjd_love_zzt/article/details/44259909

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!