码迷,mamicode.com
首页 > 其他好文 > 详细

最短的名字

时间:2015-03-14 18:39:13      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

Description

在一个奇怪的村子中,很多人的名字都很长,比如aaaaa, bbb and abababab。
名字这么长,叫全名显然起来很不方便。所以村民之间一般只叫名字的前缀。比如叫‘aaaaa‘的时候可以只叫‘aaa‘,因为没有第二个人名字的前三个字母是‘aaa‘。不过你不能叫‘a‘,因为有两个人的名字都以‘a‘开头。村里的人都很聪明,他们总是用最短的称呼叫人。输入保证村里不会有一个人的名字是另外一个人名字的前缀(作为推论,任意两个人的名字都不会相同)。
如果村里的某个人要叫所有人的名字(包括他自己),他一共会说多少个字母?

Input

输入第一行为数据组数T (T<=10)。每组数据第一行为一个整数n(1<=n<=1000),即村里的人数。以下n行每行为一个人的名字(仅有小写字母组成)。输入保证一个村里所有人名字的长度之和不超过1,000,000。

Output

对于每组数据,输出所有人名字的字母总数。

Sample Input

1
3
aaaaa
bbb
abababab 

Sample Output

5 
#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;

const int maxn=1000+5;
string a[maxn];

int dfs(int first,int last,int d)
{
	if(first+1==last) return 0;
	int l=first,temp=a[first][d],res=last-first;
	for(int i=first;i<last;i++)
	{
		if(temp!=a[i][d])
		{
			res+=dfs(l,i,d+1);
			l=i;
			temp=a[i][d];
		}
		if(i==last-1&&temp==a[i][d]) res+=dfs(l,i+1,d+1);
	}
	return res;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i,n;
		scanf("%d",&n);
		for(i=0;i<n;i++) cin>>a[i];
		if(n==1) {printf("1\n"); continue;}
		sort(a,a+n);
		printf("%d\n",dfs(0,n,0));
	}
	return 0;
}


最短的名字

标签:

原文地址:http://blog.csdn.net/hynu_zhizuzhe/article/details/44261049

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!