码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1052 Tian Ji -- The Horse Racing

时间:2015-03-14 20:04:31      阅读:144      评论:0      收藏:0      [点我收藏+]

标签:

Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian‘s. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king‘s regular, and his super beat the king‘s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

技术分享

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian‘s horses on one side, and the king‘s horses on the other. Whenever one of Tian‘s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input

3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output

200 0 0
 

题意:田忌和齐王赛马,输出有多少马,然后田忌的每匹马的速度,齐王的每匹马的速度,赢一场得100输一场输100,文田忌最后能赢多少


#include <iostream>
#include<map>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[10010];
int b[10010];
int cmp(int a,int b)
{
    return a>b;
}
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<n; i++)
            scanf("%d",&b[i]);
        sort(a,a+n,cmp);
        sort(b,b+n,cmp);
        int win=0,lose=0;
        int n1=n-1;
        n=n-1;
        for(int i=0,j=0; i<=n1&&j<=n;)
        {
            if(a[i]>b[j])   //田忌最快的马和齐王最快的马比较,田忌的胜利
            {
                win++;
                j++;
                i++;
            }
            else if(a[i]<b[j]) //田忌最快的马和齐王最快的马比较,齐王的胜利
            {
                lose++;
                n1--;
                j++;
            }
            else                  //田忌最快的马和齐王最快的马比较,一样
            { 
                if(a[n1]>b[n])    //比较两个人最慢的马 ,田忌的快
                {
                    n1--;
                    n--;
                    win++;
                }
                else if(a[n1]<b[n])  //比较两个人最慢的马 ,齐王的快 
                {
                    j++;
                    n1--;
                    lose++;
                }
                else                  //比较两个人最慢的马 ,一样快
                {
                    if(a[n1]<b[j])          //这里是重点看解释1。。。
                    {
                        n1--;
                        j++;
                        lose++;
                    }
                    else
                    {
                      i++;
                      j++;
                    }
                }
            }
        }
        printf("%d\n",(win-lose)*200);
    }
    return 0;
}

解释1:举个例子

3

28   20   16 

28   21    16

如果前后都相同并且后面的小于前面的那么就优先发挥快马的优势



HDU 1052 Tian Ji -- The Horse Racing

标签:

原文地址:http://blog.csdn.net/wweiainn/article/details/44262429

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!