码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 147 - Dollars (集合上的动态规划)

时间:2015-03-15 18:28:11      阅读:268      评论:0      收藏:0      [点我收藏+]

标签:acm   uva   动态规划   algorithm   

UVA - 147

Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

 Status

Description

技术分享

New Zealand currency consists of $100, $50, $20, $10, and $5 notes and $2, $1, 50c, 20c, 10c and 5c coins. Write a program that will determine, for any given amount, in how many ways that amount may be made up. Changing the order of listing does not increase the count. Thus 20c may be made up in 4 ways: 1 技术分享 20c, 2 技术分享 10c, 10c+2 技术分享 5c, and 4 技术分享 5c.

Input

Input will consist of a series of real numbers no greater than $300.00 each on a separate line. Each amount will be valid, that is will be a multiple of 5c. The file will be terminated by a line containing zero (0.00).

Output

Output will consist of a line for each of the amounts in the input, each line consisting of the amount of money (with two decimal places and right justified in a field of width 6), followed by the number of ways in which that amount may be made up, right justified in a field of width 17.

Sample input

0.20
2.00
0.00

Sample output

  0.20                4
  2.00              293

Source

Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 3. Problem Solving Paradigms :: Dynamic Programming :: Coin Change - Classical
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) :: Volume 5. Dynamic Programming 
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming :: Coin Change (CC)
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming :: Coin Change (CC)

 Status







思路:简单的动态规划问题,因为每个面值都是5cent的整数倍,所以将所有面值都转化为5cent的倍数,即{1, 2, 4, 10, 20, 40, 100, 200, 400, 1000, 2000};

输入的那个数也转化为5的倍数,注意浮点数问题

然后dp预处理下,输出记得域宽要按照要求来,这里dp因为会爆int,要开到LL型


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define LL long long
using namespace std;

const double eps = 1e-7;
double n;
LL dp[6005];
int val[11] = {1, 2, 4, 10, 20, 40, 100, 200, 400, 1000, 2000};

void init() {
	memset(dp, 0, sizeof(dp));
	dp[0] = 1;
	for(int i = 0; i < 11; i++) {
		for(int j = 0; j < 6005; j++) {
			if(j >= val[i]) dp[j] += dp[j-val[i]];
		}
	}
}

int main() {
	init();
	while(scanf("%lf", &n) != EOF) {
		if( (n - 0) < eps) break;
		int num = (int)( (n + 0.01) / 0.05 );
		printf("%6.2lf%17lld\n", n, dp[num]);
	}
	return 0;
} 













UVA - 147 - Dollars (集合上的动态规划)

标签:acm   uva   动态规划   algorithm   

原文地址:http://blog.csdn.net/u014355480/article/details/44278425

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!