码迷,mamicode.com
首页 > 其他好文 > 详细

(数学)hdu 1205

时间:2015-03-15 19:44:15      阅读:112      评论:0      收藏:0      [点我收藏+]

标签:

吃糖果

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 26515    Accepted Submission(s): 7533


Problem Description
HOHO,终于从Speakless手上赢走了所有的糖果,是Gardon吃糖果时有个特殊的癖好,就是不喜欢将一样的糖果放在一起吃,喜欢先吃一种,下一次吃另一种,这样;可是Gardon不知道是否存在一种吃糖果的顺序使得他能把所有糖果都吃完?请你写个程序帮忙计算一下。
 

 

Input
第一行有一个整数T,接下来T组数据,每组数据占2行,第一行是一个整数N(0<N<=1000000),第二行是N个数,表示N种糖果的数目Mi(0<Mi<=1000000)。
 

 

Output
对于每组数据,输出一行,包含一个"Yes"或者"No"。
 

 

Sample Input
2 3 4 1 1 5 5 4 3 2 1
 

 

Sample Output
No Yes
Hint
Hint
Please use function scanf
 

 

Author
Gardon
 

 

Source
 

 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1201 1021 1008 1234 1071 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define LL long long
int tt,n,maxx;
LL sum;
int main()
{
    int x;
    scanf("%d",&tt);
    while(tt--)
    {
        sum=0,maxx=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&x);
            sum+=x;
            if(x>maxx)
                maxx=x;
        }
        if(2*maxx-sum<=1)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

  

(数学)hdu 1205

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4340137.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!