码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU 1021 Fibonacci Again

时间:2015-03-16 17:57:23      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:c++   acm   杭电   算法   编程   

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41156    Accepted Submission(s): 19705


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
0 1 2 3 4 5
 

Sample Output
no no yes no no no
 

Author
Leojay
 
 
我说这个题目想当有意思,首先上去就做,压根就没考虑数组溢出n到几百就不行了;最关键的一点是题目要求一种是与否的判断,那就好好找找规律,结果直接让他输出100个f【n】看是否能被3整除的数据是如何分布的,立刻就遇到了惊喜!请看:
#include<iostream>
using namespace std;

int main()
{
	int n;
	int *ls=new int [10000000];
	ls[0]=7;ls[1]=11;
	for(int i=2;i<100;i++)
	{
		ls[i]=ls[i-1]+ls[i-2];
		/*if(ls[i]%3==0)
	      cout<<"yes"<<" ";
		  else
		  cout<<"no"<<" ";*/
	}
while(cin>>n)
{

	
printf((n-1)%4==1?"yes\n":"no\n");
}
//printf(ls[n]%3?"no":"yes");
return 0;
}

技术分享
结果AC代码能猜出几行么!!呵呵呵

#include<iostream>
using namespace std;

int main()
{
	int n;
	while(cin>>n)
	{
		printf((n-1)%4==1?"yes\n":"no\n");
	}
return 0;
}

杭电 HDU 1021 Fibonacci Again

标签:c++   acm   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44307813

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!