码迷,mamicode.com
首页 > 其他好文 > 详细

(区间型dp) poj 2955

时间:2015-03-16 20:52:12      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:

Brackets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3615   Accepted: 1874

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<string>
#include<algorithm>
using namespace std;
char s[105];
int maxx,dp[105][105];
int main()
{
    while(scanf("%s",s)!=EOF)
    {
        if(strcmp(s,"end")==0)
            break;
        memset(dp,0,sizeof(dp));
        maxx=0;
        int len=strlen(s);
        for(int i=0;i<len;i++)
        {
            for(int j=0,k=i;k<len;j++,k++)
            {
                if((s[j]==‘(‘&&s[k]==‘)‘||(s[j]==‘[‘&&s[k]==‘]‘)))
                    dp[j][k]=dp[j+1][k-1]+2;
                for(int t=j+1;t<k;t++)
                {
                    if(dp[j][t]+dp[t][k]>dp[j][k])
                        dp[j][k]=dp[j][t]+dp[t][k];
                }
                if(dp[j][k]>maxx)
                    maxx=dp[j][k];
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}

  

(区间型dp) poj 2955

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4342626.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!