码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1525 Euclid's Game 博弈

时间:2015-03-17 23:45:59      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:博弈

Euclid‘s Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2219    Accepted Submission(s): 1000


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

 

Sample Input
34 12 15 24 0 0
 

Sample Output
Stan wins Ollie wins
 


题意:stan先操作。  每次操作可以把 当前 大的数减去 小的数的任意正整数倍,只要不要出现负数就行了。谁操作完出现0 ,那么就是谁胜。


做法:当前比较大的数是n,比较小的数是m的话。那么如果n/m大于不等于1,那么当前这个人可以通过- (n/m)*m 还是- (n/m-1)*m 来决定 谁先面临n 比m 小的 局面。 也就是说,那个人会有一次 必胜的选择机会,谁先得到这个机会,谁就赢了。  如果这种机会没出现的话,那么每次 大的数 只能减小的数*1。那么就这样 按次序减下来,就可以得到谁是赢家了。


#include <stdio.h>
#include <stdlib.h>
#include <string.h> 
#include <string>
#include <iostream>
#include <algorithm>
using namespace std; 
#include <vector> 


void deal(int n,int m)
{
	if(n<m)
		swap(n,m);
	int bu=0;//总
	int tem=-1;//最先第几步可以选择 
	while(m)
	{    
		if(n/m!=1&&tem==-1) 
			tem=bu+1; 

		n-=n/m*m; 
		swap(n,m);
		bu++;

	} 
	if(tem==-1)
	{
		if(bu&1)//总步数
			puts("Stan wins");
		else
			puts("Ollie wins");
	}
	else if(tem&1)//第几步出现 可以选择的几何
		puts("Stan wins");
	else
		puts("Ollie wins");
}

int main()
{
	int n,m;
	while(cin>>n>>m,n||m)
	{
		deal(n,m);
	}

	return 0;
}





hdu 1525 Euclid's Game 博弈

标签:博弈

原文地址:http://blog.csdn.net/u013532224/article/details/44353915

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!