码迷,mamicode.com
首页 > 其他好文 > 详细

【DP|多重背包可行性】POJ-1014 Dividing

时间:2015-03-18 16:00:19      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:

Dividing
Time Limit: 1000MS Memory Limit: 10000K

Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input
Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , … , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line “1 0 1 2 0 0”. The maximum total number of marbles will be 20000.
The last line of the input file will be “0 0 0 0 0 0”; do not process this line.

Output
For each collection, output “Collection #k:”, where k is the number of the test case, and then either “Can be divided.” or “Can’t be divided.”.
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output

Collection #1:
Can’t be divided.

Collection #2:
Can be divided.

Source
Mid-Central European Regional Contest 1999


题意: 给出六种石头,体积从1到6,每种若干个,问能否分成两堆,使之体积相同。
思路: 多重背包问题,没有价值,只询问可行性。dp[i][j],i表示前i种石头,j表示当前背包内容量,dp[i][j]表示用了前i种石头、背包容量为j的时候还剩下多少块第i种石头。
代码如下:

/*
 * ID: j.sure.1
 * PROG:
 * LANG: C++
 */
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <iostream>
#define PB push_back
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-8;
/****************************************/
const int N = 10, M = 12e4 + 5;
int num[N], dp[N][M];

bool solve(int P)
{
    memset(dp, 0, sizeof(dp));
    for(int j = 1; j <= P; j++) {
        dp[0][j] = -1;
    }
    for(int i = 1; i <= 6; i++) {
        for(int j = 0; j <= P; j++) {
            if(dp[i-1][j] >= 0) dp[i][j] = num[i];
            else {
                dp[i][j] = -1;
            }
        }
        for(int j = 0; j <= P-i; j++) {
            if(dp[i][j] > 0) {
                dp[i][j+i] = max(dp[i][j] - 1, dp[i][j+i]);
            }
        }
    }
    if(~dp[6][P]) return true;
    return false;
}

int main()
{
#ifdef J_Sure
    freopen("000.in", "r", stdin);
    //freopen("999.out", "w", stdout);
#endif
    int cas = 1;
    while(1) {
        int all = 0;
        for(int i = 1; i <= 6; i++) {
            scanf("%d", &num[i]);
            all += i * num[i];
        }
        if(!all) break;
        printf("Collection #%d:\n", cas++);
        bool ok;
        if(all & 1) {
            puts("Can‘t be divided.\n");
            continue ;
        }
        ok = solve(all >> 1);
        if(ok) puts("Can be divided.\n");
        else puts("Can‘t be divided.\n");
    }
    return 0;
}

【DP|多重背包可行性】POJ-1014 Dividing

标签:

原文地址:http://blog.csdn.net/j_sure/article/details/44410389

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!