码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3329 One Person Game (概率dp 难)

时间:2015-03-18 18:08:58      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:概率dp

There is a very simple and interesting one-person game. You have 3 dice, namely Die1, Die2 and Die3. Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1, K2, K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter‘s number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers n, K1, K2, K3, a, b, c (0 <= n <= 500, 1 < K1, K2, K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

参考  bin神 的博客,如果自己做绝对做不出,数学不好真是硬伤

http://www.cnblogs.com/kuangbin/archive/2012/10/03/2710648.html




#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
//typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 1005

double p[N],dp[N];
double A[N],B[N];
int a,b,c,n,k1,k2,k3;
double pp;

int main()
{
	int i,j,s;
	int t;
	sf(t);
	while(t--)
	{
        sf(n);
		sfff(k1,k2,k3);
		sfff(a,b,c);
		mem(p,0);
		pp=1.0/k1/k2/k3;

		fre(i,1,k1+1)
		 fre(j,1,k2+1)
		  fre(s,1,k3+1)
		    if(i!=a||j!=b||s!=c)
			  p[i+j+s]+=pp;

	   mem(A,0);
	   mem(B,0);

	   free(i,n,0)
	    {
             A[i]=pp;
             B[i]=1;

	    	fre(j,3,k1+k2+k3+1)
	    	  {
	    	  	 A[i]+=p[j]*A[i+j];
	    	  	 B[i]+=p[j]*B[i+j];
	    	  }
	    }

		double ans=B[0]/(1-A[0]);

		pf("%.15f\n",ans);

	}
    return 0;
}





ZOJ 3329 One Person Game (概率dp 难)

标签:概率dp

原文地址:http://blog.csdn.net/u014737310/article/details/44414105

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!