码迷,mamicode.com
首页 > 其他好文 > 详细

NYoj 1112 求次数 【水】

时间:2015-03-18 20:32:23      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

求次数

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述

题意很简单,给一个数n 以及一个字符串str,区间【i,i+n-1】 为一个新的字符串,i 属于【0,strlen(str)】如果新的字符串出现过ans++,例如:acmacm n=3,那么 子串为acm cma mac acm ,只有acm出现过

求ans;

输入
LINE 1: T组数据(T<10)
LINE 2: n ,n <= 10,且小于strlen(str);
LINE 3:str
str 仅包含英文小写字母 ,切长度小于10w
输出
求 ans
样例输入
2
2
aaaaaaa
3
acmacm
样例输出
5
1

就是将所有的都存起来,排个序,遍历

代码:

 
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
const int M = 200000;
using namespace std;

struct node{
	char str[12];
}s[M];
char str[M];

bool cmp(node a, node b){
	if( strcmp(a.str, b.str) <= 0 ) return 1;
	return 0;
}

int main(){
	int t, n;
	scanf("%d", &t);
	while(t --){
		scanf("%d%s", &n, str);
		int len = strlen(str);
	//	memset(s, 0, sizeof(s));
		for(int i = 0; i <= len-n; ++ i){
			for(int j = 0; j < n; ++ j)
				s[i].str[j] = str[j+i];
			s[i].str[n] = '\0';
		}
		sort(s, s+len-n+1, cmp);
		int ans = 0;
		for(int i = 1; i <= len-n; ++ i){
			if(strcmp(s[i].str, s[i-1].str) == 0) ++ans;
		}
		printf("%d\n", ans);
	}
	return 0;
}        


NYoj 1112 求次数 【水】

标签:

原文地址:http://blog.csdn.net/shengweisong/article/details/44419337

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!