码迷,mamicode.com
首页 > 其他好文 > 详细

【原创】poj ----- 2524 Ubiquitous Religions 解题报告

时间:2015-03-18 23:02:27      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:

题目地址:

http://poj.org/problem?id=2524

 

题目内容:

Ubiquitous Religions
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 26119   Accepted: 12859

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source

 
 
解题思路:
 
水题。很单纯的并查集问题,就是见人就合并,最后统计有几个集合然后输出。
如何计算总共有几个集合?
可以看出,有n个人,因此,初始化的时候有n个集合。当前两个人如果需要合并,那么n - 1,如果不需要,就直接跳过。最后输出还剩几个集合便是答案。
 
 
全部代码:
#include <stdio.h>

int set[50001];
int n,m;

int find_father(int son)
{
  if (set[son] == 0) {
    return son;
  }
  return set[son] = find_father(set[son]);
}

void init()
{
  for (int i = 0; i < n; i ++) {
    set[i] = 0;
  }
}

int main(void)
{
  int count = 1;
  int man1,man2;
  while (scanf("%d%d", &n, &m)) {
    if (m == 0 && n == 0)
      break;
    int res = n;
    for (int i = 0; i < m; i ++) {
      scanf("%d%d", &man1, &man2);
      int fat1 = find_father(man1);
      int fat2 = find_father(man2);
      if (fat1 != fat2) {
    set[fat2] = fat1;
    res --;   // 合并一次,减少一个集合
      }
    }
    printf("Case %d: %d\n", count, res);
    init();
    count ++;
  }
  return 0;
}

 

【原创】poj ----- 2524 Ubiquitous Religions 解题报告

标签:

原文地址:http://www.cnblogs.com/shadowmydx/p/4348765.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!