码迷,mamicode.com
首页 > 其他好文 > 详细

Ant Counting (poj 3046 分组背包)

时间:2015-03-19 22:06:47      阅读:149      评论:0      收藏:0      [点我收藏+]

标签:ant counting   poj 3046   分组背包   

Language:
Ant Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3142   Accepted: 1246

Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants! 

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants. 

How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed? 

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were: 

3 sets with 1 ant: {1} {2} {3} 
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3} 
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3} 
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3} 
1 set with 5 ants: {1,1,2,2,3} 

Your job is to count the number of possible sets of ants given the data above. 

Input

* Line 1: 4 space-separated integers: T, A, S, and B 

* Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

Output

* Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

Sample Input

3 5 2 3
1
2
2
1
3

Sample Output

10

Hint

INPUT DETAILS: 

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made? 


OUTPUT DETAILS: 

5 sets of ants with two members; 5 more sets of ants with three members

Source


题意:给出T个数字,编号1~T,每个数字有N[i]个。用这些数字组成一个序列,最后问长度在S~B之间的不同序列有多少种。

思路:分组背包。每个蚂蚁家族为一个分组,在每个分组里的选择有N[i]种(选1~N[i])。背包九讲

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:102400000,102400000")
#define maxn 1005
#define MAXN 2005
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
#define lson rt<<1,l,mid
#define rson rt<<1|1,mid+1,r
#define FRE(i,a,b)  for(i = a; i <= b; i++)
#define FREE(i,a,b) for(i = a; i >= b; i--)
#define FRL(i,a,b)  for(i = a; i < b; i++)
#define FRLL(i,a,b) for(i = a; i > b; i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define DBG         pf("Hi\n")
typedef long long ll;
using namespace std;

int dp[maxn*100];
int num[maxn];
int t,a,s,b;

int main()
{
    int i,j,x,k;
    while (scanf("%d%d%d%d",&t,&a,&s,&b)!=EOF)
    {
        mem(num,0);
        mem(dp,0);
        FRE(i,1,a)
        {
            sf(x);
            num[x]++;
        }
        dp[0]=1;
        FRE(i,1,t)
        {
            FREE(j,a,0)
            {
                FRE(k,1,num[i])
                {
                    if (j-k>=0)
                    {
                        dp[j]=(dp[j]+dp[j-k])%1000000;
                    }
                }
            }
        }
        int ans=0;
        FRE(i,s,b)
            ans=(ans+dp[i])%1000000;
        pf("%d\n",ans);
    }
    return 0;
}




Ant Counting (poj 3046 分组背包)

标签:ant counting   poj 3046   分组背包   

原文地址:http://blog.csdn.net/u014422052/article/details/44464009

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!