码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ---题目94cigarettes

时间:2015-03-19 22:14:10      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:

cigarettes

时间限制:3000 ms  |  内存限制:65535 KB
难度:2
描述

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?

输入
First input is a single line,it‘s n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124
来源
[rooot]原创
上传者

rooot


题意:Tom爱吸烟,刚开时给他n根烟,再输入一个K表示每k根烟可以换一个新的烟;第一行输出一个3代表有3组测试数据,每组该出一个n和k ;

代码如下:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int main()
{
    int test,n,m,t;
    int sum;
    cin>>test;
    while(test--)
    {
        sum=0;
        cin>>n>>m;
        int t=n;
        while(n>=m)       //n>=m就进入循环
        {
            sum+=n/m;
            n=n/m+n%m;
        }
        printf("%d\n",t+sum);

    }
    return 0;
}



NYOJ---题目94cigarettes

标签:

原文地址:http://blog.csdn.net/qq_qingtian/article/details/44461357

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!