To The Max
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8882 Accepted Submission(s): 4288
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
Source
Greater New York 2001
代码:
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#include<algorithm>
#include<vector>
#include<string.h>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<sstream>
#include<time.h>
#include<malloc.h>
using namespace std;
const int MAXN = 1010;
int n;
int p[MAXN][MAXN];
int longmax(int a[],int n)
{
int b = 0;
int ans = -10000000;
for(int i=0;i<n;i++)
{
if (b>0)
b+= a[i];
else b= a[i];
ans = max (ans,b);
}
return ans;
}
int work()
{
int t[1010];
int ans = -10000000;
for(int i=0;i<n;i++)
{
memset(t,0,sizeof(t));
for(int j = i;j<n;j++)//枚举第i到第j行的所有可能矩阵的和
{
int k;
for(k=0;k<n;k++)
{
t[k] += p[j][k];
}
int tt = longmax(t,k);
ans = max(ans,tt);
}
}
return ans;
}
int main()
{
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
{
scanf("%d",&p[i][j]);
}
int ans = work();
printf("%d\n",ans);
}
return 0;
}
原文地址:http://blog.csdn.net/u014427196/article/details/44461053