码迷,mamicode.com
首页 > 其他好文 > 详细

poj3267——线性dp

时间:2015-03-19 23:41:31      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:

poj3267——线性dp

The Cow Lexicon
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 8458   Accepted: 3993

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters ‘a‘..‘z‘. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range ‘a‘..‘z‘) of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively: W and L 
Line 2: L characters (followed by a newline, of course): the received message 
Lines 3..W+2: The cows‘ dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

题意:删掉给定单词的部分字母使之能由词典中的单词组合而成,求删掉的最少字母数量
思路:dp,dp[i]=min{dp[i+1]+1,dp[ps]+(i-ps-len)},dp[i]表示从第i位起的后缀中删掉的最少字母数量使该后缀能由词典中的单词合成,答案即为dp[0]
技术分享
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>

using namespace std;

const int maxn=1010;
int W,L;
string str,dict[maxn];
int dp[maxn];

int main()
{
    while(cin>>W>>L){
        cin>>str;
        for(int i=0;i<W;i++) cin>>dict[i];
        dp[L]=0;
        for(int i=L-1;i>=0;i--){
            dp[i]=dp[i+1]+1;
            for(int k=0;k<W;k++){
                int len=dict[k].length();
                if(dict[k][0]!=str[i]) continue;
                int ps=i,pd=0;
                while(ps<L&&pd<len&&L-ps>=len-pd){
                    if(dict[k][pd]==str[ps]) pd++;
                    ps++;
                }
                if(pd==len) dp[i]=min(dp[i],dp[ps]+(ps-i-len));
            }
        }
        cout<<dp[0]<<endl;
    }
    return 0;
}
View Code

 

 

2015-03-19 22:20:21

poj3267——线性dp

标签:

原文地址:http://www.cnblogs.com/--560/p/4351955.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!