码迷,mamicode.com
首页 > 其他好文 > 详细

[LOJ 1008] Fibsieve`s Fantabulous Birthday

时间:2015-03-20 01:20:25      阅读:264      评论:0      收藏:0      [点我收藏+]

标签:

A - Fibsieve`s Fantabulous Birthday
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Description

Fibsieve had a fantabulous (yes, it‘s an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

 

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5

题意:给出一张图,以及一个点,求出这个点的坐标

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
#define ll long long

ll n;

void solve()
{
    ll floor=(ll)sqrt(n);
    if(floor*floor!=n) floor++; //确定层数
    ll dir=floor&1;             //确定方向,0表示左右下,1表示下上左
    ll num=n-((floor-1)*(floor-1)); //当前层序号
    if(dir==0)
    {
        if(num<=floor)
        {
            printf("%lld %lld\n",num,floor);
        }
        else
        {
            num=floor-(num-floor);
            printf("%lld %lld\n",floor,num);
        }
    }
    else
    {
        if(num<=floor)
        {
            printf("%lld %lld\n",floor,num);
        }
        else
        {
            num=floor-(num-floor);
            printf("%lld %lld\n",num,floor);
        }
    }
}
int main()
{
    int T,iCase=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld",&n);
        printf("Case %d: ",iCase++);
        solve();
    }
    return 0;
}

 

[LOJ 1008] Fibsieve`s Fantabulous Birthday

标签:

原文地址:http://www.cnblogs.com/hate13/p/4352319.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!