码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU 1037 Keep on Truckin'

时间:2015-03-20 09:23:01      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   编程   

Keep on Truckin‘

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9881    Accepted Submission(s): 6859


Problem Description
Boudreaux and Thibodeaux are on the road again . . .

"Boudreaux, we have to get this shipment of mudbugs to Baton Rouge by tonight!"

"Don‘t worry, Thibodeaux, I already checked ahead. There are three underpasses and our 18-wheeler will fit through all of them, so just keep that motor running!"

"We‘re not going to make it, I say!"

So, which is it: will there be a very messy accident on Interstate 10, or is Thibodeaux just letting the sound of his own wheels drive him crazy?
 

Input
Input to this problem will consist of a single data set. The data set will be formatted according to the following description.

The data set will consist of a single line containing 3 numbers, separated by single spaces. Each number represents the height of a single underpass in inches. Each number will be between 0 and 300 inclusive.
 

Output
There will be exactly one line of output. This line will be:

   NO CRASH

if the height of the 18-wheeler is less than the height of each of the underpasses, or:

   CRASH X

otherwise, where X is the height of the first underpass in the data set that the 18-wheeler is unable to go under (which means its height is less than or equal to the height of the 18-wheeler).
The height of the 18-wheeler is 168 inches.
 

Sample Input
180 160 170
 

Sample Output
CRASH 160
 

Source
 

大晚上的欺负我智商!他妈的蛋。

#include<iostream>
int main()
{
	using namespace std;
	int n,m,k;
	while(cin>>n>>m>>k)
	{
		if(n<=168)
			cout<<"CRASH "<<n<<endl;
		if(m<=168)
			cout<<"CRASH "<<m<<endl;
		if(k<=168)
            cout<<"CRASH "<<k<<endl;
		if(n>168&&m>168&&k>168)
			cout<<"NO CRASH"<<endl;
	}
	return 0;
}


 

杭电 HDU 1037 Keep on Truckin'

标签:acm   c++   杭电   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44480393

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!