码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4259 Double Dealing(置换群)

时间:2015-03-20 14:35:06      阅读:121      评论:0      收藏:0      [点我收藏+]

标签:

Double Dealing

Time Limit: 50000/20000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1893    Accepted Submission(s): 672


Problem Description
Take a deck of n unique cards. Deal the entire deck out to k players in the usual way: the top card to player 1, the next to player 2, the kth to player k, the k+1st to player 1, and so on. Then pick up the cards – place player 1′s cards on top, then player 2, and so on, so that player k’s cards are on the bottom. Each player’s cards are in reverse order – the last card that they were dealt is on the top, and the first on the bottom.
How many times, including the first, must this process be repeated before the deck is back in its original order?
 

Input
There will be multiple test cases in the input. Each case will consist of a single line with two integers, n and k (1≤n≤800, 1≤k≤800). The input will end with a line with two 0s.
 

Output
For each test case in the input, print a single integer, indicating the number of deals required to return the deck to its original order. Output each integer on its own line, with no extra spaces, and no blank lines between answers. All possible inputs yield answers which will fit in a signed 64-bit integer.
 

Sample Input
1 3 10 3 52 4 0 0
 

Sample Output
1 4 13
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  4257 4258 4260 4261 4262 
 

1. n张牌 (1,2,···,n) 按顺序发给k个人,再把牌收回,第1个人的放最上面,后面的依次放下面。继续发牌,收牌,问多少次后恢复原样。

2. 以 n=10,k=3 为例,4次后牌的次序恢复原样,如下:

第一次: 10  7  4   1   8   5   2   9   6   3
第二次: 3   2  1   10  9   8   7   6   5   4
第三次: 4   7  10  3   6   9   2   5   8   1
第四次: 1   2  3    4   5   6   7   8   9   10

3. 经过 1 次操作(发牌+收牌)后,下标变化情况如下:

原次序:1  2  3    4  5  6  7  8  9  10
操作后:4  7  10  3  6  9  2  5  8  1

4. 显然,该操作为一个置换,且为:

技术分享

5. n 元数码上的任意置换 σ 都可唯一地表示成不相交的循环置换的乘积。

6. lcm(x,y)=xy/gcd(x,y).

7. lcm(x1,x2,···,xn)=lcm(lcm(x1,x2,···,xn-1),xn).

8. 本题所求即为各循环置换的循环节的最小公倍数。以 n=10,k=3 为例,所求为 lcm(4,2,4)=4.

ac代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
__int64 gcd(__int64 a,__int64 b)
{
	int t;
	if(a<b)
	{
		t=a;
		a=b;
		b=t;
	}
	if(b==0)
		return a;
	return gcd(b,a%b);
}
__int64 lcm(__int64 a,__int64 b)
{
	return a/gcd(a,b)*b;
}
int vis[100100],next[100100];
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF,n||m)
	{
		int i,j,k=n;
		if(n<=m)
		{
			printf("1\n");
			continue;
		}
		for(i=m;i>=1;i--)
		{
			for(j=i;j<=n;j+=m)
			{
				next[k--]=j;
			}
		}
		__int64 ans=1;
		memset(vis,0,sizeof(vis));
		for(i=1;i<=n;i++)
		{
			if(vis[i])
				continue;
			__int64 temp=next[i],res=1;
			while(temp!=i)
			{
				vis[temp]=1;
				temp=next[temp];
				res++;
			}
			ans=lcm(ans,res);
		}
		printf("%I64d\n",ans);
	}
}


HDOJ 4259 Double Dealing(置换群)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44489241

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!