码迷,mamicode.com
首页 > 其他好文 > 详细

poj3176——dp

时间:2015-03-20 20:08:36      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:

poj3176——dp

Cow Bowling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14683   Accepted: 9764

Description

The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7


3 8

8 1 0

2 7 4 4

4 5 2 6 5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30
题意:求从三角形顶端向下走的最大和
dp水题
技术分享
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<stdlib.h>

using namespace std;

const int maxn=1010;
int N;
int a[maxn][maxn];
int dp[maxn][maxn];

int main()
{
    scanf("%d",&N);
    for(int i=1;i<=N;i++){
        for(int j=1;j<=i;j++){
            scanf("%d",&a[i][j]);
        }
    }
    memset(dp,0,sizeof(dp));
    for(int i=N;i>=1;i--){
        for(int j=1;j<=i;j++){
            dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+a[i][j];//因dp初始化时已清零,所以第N+1层为0
        }
    }
    printf("%d\n",dp[1][1]);
    return 0;
}
View Code

 

poj3176——dp

标签:

原文地址:http://www.cnblogs.com/--560/p/4354358.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!