码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目1498 50 years, 50 colors(最小点覆盖)

时间:2015-03-20 22:05:21      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1792    Accepted Submission(s): 981


Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it‘s so nice, isn‘t it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What‘s more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

技术分享

 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

Sample Input
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output
-1 1 2 1 2 3 4 5 -1
 

Author
8600
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:  1507 1528 1533 1497 1493 
 
ac代码
#include<stdio.h>
#include<string.h>
#include<set>
#include<iostream>
using namespace std;
int ans[101],n,k;
int map[1010][1010],g[1010][1010];
int link[1010],vis[1010];
int dfs(int u)
{
	int i;
	for(i=1;i<=n;i++)
	{
		if(!vis[i]&&g[u][i])
		{
			vis[i]=1;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=u;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	//int n,k;
	while(scanf("%d%d",&n,&k)!=EOF,n||k)
	{
		int i,j;
		set<int>m;
		set<int>::iterator it;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				scanf("%d",&map[i][j]);
				m.insert(map[i][j]);
			}
		}
		int x=0;
		for(it=m.begin();it!=m.end();it++)
		{
			int num=*it;
			for(i=1;i<=n;i++)
			{
				for(j=1;j<=n;j++)
				{
					if(map[i][j]==num)
						g[i][j]=1;
					else
						g[i][j]=0;
				}
			}
			memset(link,-1,sizeof(link));
			int cot=0;
			for(i=1;i<=n;i++)
			{
				memset(vis,0,sizeof(vis));
				if(dfs(i))
					cot++;
			}
		//	printf("%d\n",cot);
			if(cot>k)
			{
				ans[x++]=num;
			}
		}
		if(x==0)
			printf("-1\n");
		else
		{
			for(i=0;i<x;i++)
			{
				if(i)
					printf(" %d",ans[i]);
				else
					printf("%d",ans[i]);
			}
			printf("\n");
		}
	}
}


HDOJ 题目1498 50 years, 50 colors(最小点覆盖)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44497143

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!