码迷,mamicode.com
首页 > 其他好文 > 详细

hduoj1159 dp,lcs

时间:2015-03-21 06:19:55      阅读:141      评论:0      收藏:0      [点我收藏+]

标签:

hduoj1159  dp,lcs

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25570    Accepted Submission(s): 11363


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

 

Sample Output
4 2 0
 求lcs,水题,用了滚动数组才过
技术分享
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>

using namespace std;

const int maxn=1000100;
char s[maxn],t[maxn];
int dp[2][maxn];

int main()
{
    while(scanf("%s%s",s,t)!=EOF){
        int ls=strlen(s),lt=strlen(t);
        memset(dp,0,sizeof(dp));
        char *ss=s-1,*tt=t-1;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=ls;i++){
            for(int j=1;j<=lt;j++){
                if(ss[i]==tt[j]) dp[i%2][j]=dp[(i+1)%2][j-1]+1;
                else dp[i%2][j]=max(dp[(i+1)%2][j],dp[i%2][j-1]);
            }
        }
        printf("%d\n",dp[ls%2][lt]);
    }
    return 0;
}
View Code

 

hduoj1159 dp,lcs

标签:

原文地址:http://www.cnblogs.com/--560/p/4355046.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!