码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2533 Longest Ordered Subsequence(dp)

时间:2015-03-21 09:49:34      阅读:118      评论:0      收藏:0      [点我收藏+]

标签:poj 2533 longest ord   dp   

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 36159   Accepted: 15882

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

[Submit]   [Go Back]   [Status]   [Discuss]

技术分享Home Page   技术分享Go Back  技术分享To top


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 10100
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const int INF = 1000010;

using namespace std;

int dp[N];
int n;
int a[N];

int main() {
    while(cin>>n) {
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
           int ans=-1;
        for(int i=0; i<n; i++) {
            dp[i]=1;
            for(int j=0; j<=i; j++)
                if(a[i]>a[j])dp[i]=max(dp[j]+1,dp[i]);
        ans=max(ans,dp[i]);
        }
        cout<<ans<<endl;
    }
    return 0;
}

poj 2533 Longest Ordered Subsequence(dp)

标签:poj 2533 longest ord   dp   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/44503165

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!