码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1159 Common Subsequence(dp)

时间:2015-03-21 09:50:55      阅读:98      评论:0      收藏:0      [点我收藏+]

标签:hdu 1159 common subs   dp   

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25566    Accepted Submission(s): 11361


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

Sample Output
4 2 0
 

Source
 

Recommend
Ignatius   |   We have carefully selected several similar problems for you:  1176 1058 1257 1421 1160 
 


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 1010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const int INF = 1000010;

using namespace std;

char a[N],b[N];
int dp[N][N];

int main() {
    while(~scanf("%s%s",a,b)) {
        int l1=strlen(a);
        int l2=strlen(b);
        memset(dp,0,sizeof dp);
        //dp[0][0]=1;
        for(int i=0; i<l1; i++) {
            for(int j=0; j<l2; j++) {
                if(a[i]==b[j])dp[1+i][1+j]=dp[i][j]+1;
                else
                    dp[i+1][1+j]=max(dp[i+1][j],dp[i][j+1]);
            }
        }
        printf("%d\n",dp[l1][l2]);
    }
    return 0;
}


hdu 1159 Common Subsequence(dp)

标签:hdu 1159 common subs   dp   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/44502819

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!