码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-2222

时间:2015-03-21 12:37:39      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:

  • Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39064    Accepted Submission(s): 12596


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a‘-‘z‘, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

 

Output
Print how many keywords are contained in the description.
 

 

Sample Input
1
5
she
he
say
shr
her
yasherhs
Sample Output
3
 

 

Author
Wiskey
 

 

Recommend

lcy

 

题意:看现在的主字符串,有多少个零碎的字符串构成,
做法:AC自动机模板
代码如下:
#include<iostream>
#include<string.h>
#include<algorithm>
#include<stdio.h>
#include<cmath>
#include<queue>
#define maxn 500010
using namespace std;
struct Tire
{
    int next[maxn][26],fail[maxn],end[maxn];
    int root,L;
    int newnode()
    {
        for(int i=0; i<26; i++)
        {
            next[L][i] = -1;
        }
        end[L++] = 0;
        return L-1;
    }
    void init()
    {
                    L = 0;
                    root = newnode();
    }
    void insert(char buf[])
    {
                    int len = strlen(buf);
                    int now = root;
                    for(int i=0;i<len;i++)
                    {
                              if(next[now][buf[i] - a] == -1)
                              {
                                        next[now][buf[i] -a] = newnode();
                              }
                              now = next[now][buf[i] -a];
                    }
                    end[now]++;
    }
    void build()
    {
                    queue<int>Q;
                    fail[root] = root;
                    for(int i=0;i<26;i++)
                    {
                              if(next[root][i] == -1)
                              next[root][i] = root;
                              else
                              {
                                        fail[next[root][i]] = root;
                                        Q.push(next[root][i]);
                              }
                    }
                    while(!Q.empty())
                    {
                              int now = Q.front();
                              Q.pop();
                              for(int i=0;i<26;i++)
                              {
                                       if(next[now][i] == -1)
                                       next[now][i] = next[fail[now]][i];
                                       else
                                       {
                                        fail[next[now][i]] = next[fail[now]][i];
                                        Q.push(next[now][i]);
                                       }
                              }
                    }
    }
    int query(char buf[])
    {
                    int len = strlen(buf);
                    int now = root;
                    int res = 0;
                    for(int i=0;i<len;i++)
                    {
                              now = next[now][buf[i] -a];
                              int tmp = now;
                              while(tmp != root)
                              {
                                        res += end[tmp];
                                        end[tmp] = 0;
                                        tmp = fail[tmp];
                              }
                    }
                    return res;
    }
};
char buf[1000010];
Tire ac;
int main()
{
#ifndef ONLINE_JUDGE
          freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
          int T;
          scanf("%d",&T);
          while(T--)
          {
                    int n;
                    scanf("%d",&n);
                    ac.init();
                    for(int i=0;i<n;i++)
                    {
                              scanf("%s",buf);
                              ac.insert(buf);
                    }
                    ac.build();
                    scanf("%s",buf);
                    printf("%d\n",ac.query(buf));
          }
          return 0;
}

 

HDU-2222

标签:

原文地址:http://www.cnblogs.com/chenyang920/p/4355369.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!