码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3279 Fliptile (二进制枚举+模拟)

时间:2015-03-21 20:02:20      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:poj   模拟   


Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 3992   Accepted: 1518

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

USACO 2007 Open Silver

题目链接:http://poj.org/problem?id=3279

题目大意:给一个m * n的0 1矩阵,1表示开灯,0表示关灯,按其中一个按钮,则其自身及上下左右都变成相反的状态,现在问最少需要按几次能把所有的灯都关上,若不可能输出IMPOSSIBLE,若多种情况,输出答案字典序最小的

题目分析:对于同一个点,最多操作一次,因为两次的话等于是重复操作,当一行的状态确定了,则其下面的状态全部可以递推出来,因此我们只需要枚举第一行的所有状态,然后推出全部的状态,只要最后一行都为0,则说明有解,我们只需要取解的最小值就行了

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int const MAX = 16;
int const INF = 0x3fffffff;

int a[MAX][MAX], b[MAX][MAX];
int tmp[MAX][MAX], ans[MAX][MAX];
int m, n, cnt;

int ok(int st)
{
    for(int i = 0; i < n; i++)
    {
        if((st & (1 << i)))
        {
            tmp[0][i] = 1;
            cnt ++;
            b[0][i] ^= 1;
            if(i + 1 < n)
                b[0][i + 1] ^= 1;
            if(i - 1 >= 0)
                b[0][i - 1] ^= 1;
            if(m > 1)
                b[1][i] ^= 1;
        }
    }
    for(int i = 1; i < m; i++)
    {
        for(int j = 0; j < n; j++)
        {
            if(b[i - 1][j])
            {
                tmp[i][j] = 1;
                b[i - 1][j] = 0;
                cnt ++;
                b[i][j] ^= 1;
                if(i + 1 < m)
                    b[i + 1][j] ^= 1;
                if(j + 1 < n)
                    b[i][j + 1] ^= 1;
                if(j - 1 >= 0)
                    b[i][j - 1] ^= 1;
            }
        }
    }
    for(int i = 0; i < n; i++)
        if(b[m - 1][i])
            return INF;
    return cnt;
}

int main()
{
    int mi = INF;
    bool flag = false;
    memset(a, 0, sizeof(a));
    memset(b, 0, sizeof(b));
    memset(ans, 0, sizeof(ans));
    scanf("%d %d", &m, &n);
    for(int i = 0; i < m; i++)
        for(int j = 0; j < n; j++)
            scanf("%d", &a[i][j]);
    for(int i = 0; i < (1 << n); i++)
    {
        cnt = 0;
        memset(tmp, 0, sizeof(tmp));
        memcpy(b, a, sizeof(a));
        int get = ok(i);
        if(get != INF)
        {
            flag = true;
            if(get < mi)
            {
                mi = get;
                memset(ans, 0, sizeof(ans));
                memcpy(ans, tmp, sizeof(tmp));
            }
        }
    }
    if(flag)
    {
        for(int i = 0; i < m; i++)
        {
            for(int j = 0; j < n - 1; j++)
                printf("%d ", ans[i][j]);
            printf("%d\n", ans[i][n - 1]);
        }
    }
    else
        printf("IMPOSSIBLE\n");
}


POJ 3279 Fliptile (二进制枚举+模拟)

标签:poj   模拟   

原文地址:http://blog.csdn.net/tc_to_top/article/details/44520927

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!