码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 题目Catch That Cow(BFS)

时间:2015-03-22 09:18:40      阅读:165      评论:0      收藏:0      [点我收藏+]

标签:

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 52537   Accepted: 16471

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

USACO 2007 Open Silver

ac代码

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
#define INF 0xfffffff
#define min(a,b) (a>b?b:a)
using namespace std;
struct s
{
	int pos,step;
}a,temp;
int n,k,ans,vis[100100];
void bfs()
{
	memset(vis,0,sizeof(vis));
	a.pos=n;
	a.step=0;
	queue<struct s>q;
	q.push(a);
	vis[a.pos]=1;
	while(!q.empty())
	{
		a=q.front();
		q.pop();
		for(int i=0;i<3;i++)
		{
			if(i==0)
				temp.pos=a.pos+1;
			if(i==1)
				temp.pos=a.pos-1;
			if(i==2)
				temp.pos=a.pos*2;
			temp.step=a.step+1;
			if(temp.pos==k)
			{
				ans=min(ans,temp.step);
				continue;
			}
			if(temp.pos<0||temp.pos>100001)
				continue;
			if(!vis[temp.pos])
			{
				vis[temp.pos]=1;
				q.push(temp);
			}
		}
	}
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		ans=INF;
		if(n==k)
		{
			printf("0\n");
			continue;
		}
		if(n>k)
		{
			printf("%d\n",n-k);
			continue;
		}
		bfs();
		printf("%d\n",ans);
	}
}


POJ 题目Catch That Cow(BFS)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44520057

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!