码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目1429 胜利大逃亡(续)(BFS)

时间:2015-03-22 09:20:55      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:

胜利大逃亡(续)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5811    Accepted Submission(s): 2027


Problem Description
Ignatius再次被魔王抓走了(搞不懂他咋这么讨魔王喜欢)……

这次魔王汲取了上次的教训,把Ignatius关在一个n*m的地牢里,并在地牢的某些地方安装了带锁的门,钥匙藏在地牢另外的某些地方。刚开始Ignatius被关在(sx,sy)的位置,离开地牢的门在(ex,ey)的位置。Ignatius每分钟只能从一个坐标走到相邻四个坐标中的其中一个。魔王每t分钟回地牢视察一次,若发现Ignatius不在原位置便把他拎回去。经过若干次的尝试,Ignatius已画出整个地牢的地图。现在请你帮他计算能否再次成功逃亡。只要在魔王下次视察之前走到出口就算离开地牢,如果魔王回来的时候刚好走到出口或还未到出口都算逃亡失败。
 

Input
每组测试数据的第一行有三个整数n,m,t(2<=n,m<=20,t>0)。接下来的n行m列为地牢的地图,其中包括:

. 代表路
* 代表墙
@ 代表Ignatius的起始位置
^ 代表地牢的出口
A-J 代表带锁的门,对应的钥匙分别为a-j
a-j 代表钥匙,对应的门分别为A-J

每组测试数据之间有一个空行。
 

Output
针对每组测试数据,如果可以成功逃亡,请输出需要多少分钟才能离开,如果不能则输出-1。
 

Sample Input
4 5 17 @A.B. a*.*. *..*^ c..b* 4 5 16 @A.B. a*.*. *..*^ c..b*
 

Sample Output
16 -1
 

Author
LL
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:  1180 1254 1026 1401 1175 
 
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<string>
#include<queue>
#include<iostream>
#define min(a,b) (a>b?b:a)
#define INF 0xfffffff
using namespace std;
int vis[1<<10][22][22];
char map[22][22];
int n,m,t,sx,sy,ans;
struct s
{
	int x,y,cnt,step;
}a,temp;
int dx[4]={0,1,0,-1};
int dy[4]={1,0,-1,0};
int jud(struct s a)
{
	if(a.x<0||a.x>=n||a.y<0||a.y>=m)
	{
		return 0;
	}
	if(map[a.x][a.y]=='*')
		return 0;
	if(vis[a.cnt][a.x][a.y])
		return 0;
	if(a.step>=t)
		return 0;
	return 1;
}
void bfs()
{
	memset(vis,0,sizeof(vis));
	vis[0][sx][sy]=1;
	queue<struct s>q;
	a.x=sx;
	a.y=sy;
	a.cnt=0;
	a.step=0;
	q.push(a);
	while(!q.empty())
	{
		a=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			temp.x=a.x+dx[i];
			temp.y=a.y+dy[i];
			temp.cnt=a.cnt;
			temp.step=a.step+1;
			if(!jud(temp))
			{
				continue;
			}
			if(map[temp.x][temp.y]=='^')
			{
				ans=min(ans,temp.step);
				continue;
			}
			if(map[temp.x][temp.y]>='A'&&map[temp.x][temp.y]<='Z')
			{
				int cc=temp.cnt;
				if(cc>>(map[temp.x][temp.y]-'A')&1)
				{
					vis[temp.cnt][temp.x][temp.y]=1;
					q.push(temp);
				}
				continue;
			}
			if(map[temp.x][temp.y]>='a'&&map[temp.x][temp.y]<='z')
			{
				int cc=1<<(map[temp.x][temp.y]-'a');
				temp.cnt=a.cnt|cc;
			}
			if(!vis[temp.cnt][temp.x][temp.y])
			{
				vis[temp.cnt][temp.x][temp.y]=1;
				q.push(temp);
			}
		}
	}
}
int main()
{
	while(scanf("%d%d%d",&n,&m,&t)!=EOF)
	{
		int i,j;
		for(i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='@')
				{
					sx=i,sy=j;
				}
			}
		}
		ans=INF;
		bfs();
		if(ans==INF)
			printf("-1\n");
		else
			printf("%d\n",ans);
	}
}


HDOJ 题目1429 胜利大逃亡(续)(BFS)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44518125

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!