码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目1501 Zipper(DFS)

时间:2015-03-27 22:18:20      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:

Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7223    Accepted Submission(s): 2576


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
Data set 1: yes Data set 2: yes Data set 3: no
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:  1502 1227 1158 1080 1078 
 
ac代码
#include<stdio.h>
#include<string.h>
char a[220],b[220],c[220*2];
bool flag;
int len1,len2,len3;
void dfs(int x,int y,int len)
{
	if(flag)
		return;
	if(len>=len3)
	{
		flag=true;
		return;
	}
	if(a[x]==c[len])
	{
		dfs(x+1,y,len+1);
	}
	if(b[y]==c[len])
		dfs(x,y+1,len+1);
}
int main()
{
	int t,cot=0;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%s%s",a,b,c);
		len1=strlen(a);
		len2=strlen(b);
		len3=strlen(c);
		if(len1+len2!=len3)
		{
			printf("Data set %d: no\n",++cot);
			continue;
		}
		flag=false;
		if(a[len1-1]==c[len3-1]||b[len2-1]==c[len3-1])
		{
			dfs(0,0,0);
		}
		if(flag)
			printf("Data set %d: yes\n",++cot);
		else
			printf("Data set %d: no\n",++cot);
	}
}


HDOJ 题目1501 Zipper(DFS)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44681603

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!