码迷,mamicode.com
首页 > 其他好文 > 详细

(floyd倍增) poj 3613

时间:2015-03-28 11:24:59      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:

Cow Relays
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5651   Accepted: 2230

Description

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi  ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

Input

* Line 1: Four space-separated integers: NTS, and E
* Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

Output

* Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

Sample Input

2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9

Sample Output

10

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<string>
#include<cmath>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
int n,t,s,e,res;
int hash[1010],dist[205][205],temp[205][505],f[205][205];
void floyd()
{
    while(n)
    {
        if(n&1)
        {
            memset(temp,0x3f,sizeof(temp));
            for(int k=1;k<=res;k++) for(int i=1;i<=res;i++)
            for(int j=1;j<=res;j++) temp[i][j]=min(temp[i][j],f[i][k]+dist[k][j]);
            for(int i=1;i<=res;i++) for(int j=1;j<=res;j++) f[i][j]=temp[i][j];
        }
        memset(temp,0x3f,sizeof(temp));
        for(int k=1;k<=res;k++) for(int i=1;i<=res;i++)
        for(int j=1;j<=res;j++) temp[i][j]=min(temp[i][j],dist[i][k]+dist[k][j]);
        for(int i=1;i<=res;i++) for(int j=1;j<=res;j++) dist[i][j]=temp[i][j];
        n>>=1;
    }
    return ;
}
int main()
{
    int z,x,y;
    while(scanf("%d%d%d%d",&n,&t,&s,&e)!=EOF)
    {
        res=0;
        memset(dist,0x3f,sizeof(dist));
        memset(f,0x3f,sizeof(f));
        for(int i=0;i<=200;i++) f[i][i]=0;
        memset(hash,0,sizeof(hash));
        for(int i=0;i<t;i++)
        {
            scanf("%d%d%d",&z,&x,&y);
            if(!hash[x]) hash[x]=++res;
            if(!hash[y]) hash[y]=++res;
            dist[hash[x]][hash[y]]=dist[hash[y]][hash[x]]=z;
        }
        floyd();
        printf("%d\n",f[hash[s]][hash[e]]);
    }
    return 0;
}

  

(floyd倍增) poj 3613

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4373670.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!