码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目1088 滑雪(DFS,记忆化)

时间:2015-03-28 15:50:58      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:

滑雪
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 80448   Accepted: 29995

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

Source

SHTSC 2002

ac代码

#include<stdio.h>
#include<string.h>
#define max(a,b) (a>b?a:b)
int map[1010][1010],ans,n,m,dd[1010][1010];
int dx[4]={0,1,0,-1};
int dy[4]={1,0,-1,0};
int dfs(int x,int y)
{
	//ans=max(step,ans);
	if(dd[x][y])
		return dd[x][y];
	int maxn=0;
	for(int i=0;i<4;i++)
	{
		int tx,ty;
		tx=x+dx[i];
		ty=y+dy[i];
		if(tx>=0&&tx<n&&ty>=0&&ty<m&&map[x][y]>map[tx][ty])
		{
		//	vis[tx][ty]=1;
			int s;
			s=dfs(tx,ty);
		//	vis[tx][ty]=0;
			maxn=max(s,maxn);
		}
	}
	return dd[x][y]=maxn+1;
}
int main()
{
	//int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j;
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
				scanf("%d",&map[i][j]);
		}
//		memset(vis,0,sizeof(vis));
		memset(dd,0,sizeof(dd));
		ans=0;
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				//vis[i][j]=1;
				dd[i][j]=dfs(i,j);
				ans=max(ans,dd[i][j]);
				//vis[i][j]=0;
			}
		}
		printf("%d\n",ans);
	}
}


HDOJ 题目1088 滑雪(DFS,记忆化)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44701501

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!