码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj 2051 Bitset

时间:2015-03-29 15:00:59      阅读:84      评论:0      收藏:0      [点我收藏+]

标签:

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14685    Accepted Submission(s): 11173


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

 

Input
For each case there is a postive number n on base ten, end of file.
 

 

Output
For each case output a number on base two.
 

 

Sample Input
1
2
3
 

 

Sample Output
1
10
11
 
十进制转化为二进制  太水了
 
#include<stdio.h>
#include<math.h>
int main()
{
	int n,j,sum;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;j=0;
		while(n!=0)
		{
			sum=sum+((n%2)*pow(10,j++));
			n=n/2;
		}
		printf("%d\n",sum);
	}
	return 0;
}

  

 

hdoj 2051 Bitset

标签:

原文地址:http://www.cnblogs.com/tonghao/p/4375642.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!