码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU 1164 Eddy's research I

时间:2015-03-29 23:46:20      阅读:437      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   杭电   算法   编程   

Eddy‘s research I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7117    Accepted Submission(s): 4268


Problem Description
Eddy‘s interest is very extensive, recently  he is interested in prime number. Eddy discover the  all number owned can be divided into the multiply of prime number, but  he can‘t  write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

 

Input
The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
11 9412
 

Sample Output
11 2*2*13*181
 

Author
eddy
 
 
重点是素数判定
 
#include<iostream>
#include<algorithm>
using namespace std;
int prime[65536]={0};

    
int main()
{
	for(int i=2;i<=(65535/2);i++)
	{
		int q;
		for( q=i+i;q<=65535;q+=i)
		prime[q]=1;

   }
	int ls[10000];int n;int gq[100];
	
	while(cin>>n)
	{
		int t=0;
		for(int j=2;j<=65535;j++)
		{
			if(!prime[j]&&!(n%j))
			{
				ls[t++]=j;
			    n/=j;
				if(n==1)
				break;
			}
			if(n<=j)
		
			j=1;
	}
	
	sort(ls,ls+t);
	for(int k=0;k<t-1;k++)
		cout<<ls[k]<<"*";
	cout<<ls[t-1]<<endl;
	}
return 0;
}
	

杭电 HDU 1164 Eddy's research I

标签:acm   c++   杭电   算法   编程   

原文地址:http://blog.csdn.net/lsgqjh/article/details/44732643

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!