标签:acm c++ 杭电 算法 编程
Beat the Spread!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5192 Accepted Submission(s): 2705
Problem Description
Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two
final scores, or on the absolute difference between the two scores.
Given the winning numbers for each type of bet, can you deduce the final scores?
Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final
scores.
Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
Sample Input
Sample Output
#include<iostream>
using namespace std;
int main()
{
int t,a,b;
cin>>t;
while(t--)
{int x,y;
cin>>a>>b;
if(a<b||a<0||b<0||((a+b)%2!=0))
cout<<"impossible"<<endl;
else
{
x=(a+b)/2;
y=(a-b)/2;
if(x<y)
swap(a,b);
cout<<x<<" "<<y<<endl;
}
}
return 0;
}
杭电 HDU 1194 Beat the Spread!
标签:acm c++ 杭电 算法 编程
原文地址:http://blog.csdn.net/lsgqjh/article/details/44736109