码迷,mamicode.com
首页 > 其他好文 > 详细

poj3273——经典的二分优化

时间:2015-03-30 12:36:14      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:

poj3273——经典的二分优化

Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16522   Accepted: 6570

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ‘s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

题意:将一个数组分成M段,使最大段和最小,求最大段和的最小值
思路:考虑两种极端情况:分成1组,所有的元素作为一组,则最大段和为总和Sum;分成M组,每一个元素单独作为一组,则最大段和为最大值Max。由于1<=M<=N;故最大段和肯定在[Max,Sum]的范围内,具体等于多少取决于组数M。因此在[Max,Sum]内从大到小进行遍历limit,若找到一个limit,分组数为group,如果group<=M,说明还可以继续分组使limit更小,因此继续查找,如果group>M,说明不能再分了,前一个查找的limit在M分组之下最小值了,直接退出遍历,答案即为limit。此做法时间复杂度为o(N^2),二分优化,在[Max,Sum]进行二分查找,可以使时间复杂度将为o(N*logN)。
技术分享
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>

using namespace std;

typedef long long ll;
const int maxn=1000100;
const ll INF=(1<<28);

int N,M;
ll a[maxn];

bool judge(int limit)
{
    int group=1;
    ll sum=0;
    for(int i=0;i<N;i++){
        if(sum+a[i]<=limit) sum+=a[i];
        else{
            sum=a[i];
            group++;
        }
    }
    if(group<=M) return true;///分的组数少了,还可以再分使limit更小
    return false;
}

ll BinSearch(ll low,ll high)
{
    while(low<high){
        ll mid=(low+high)/2;
        if(judge(mid)) ///期望mid越小越好,符合条件,继续找更小的
            high=mid;
        else low=mid+1; ///不符合条件,向更大的找
    }
    return high;
}

int main()
{
    while(cin>>N>>M){
        ll Max=-INF,Sum=0;
        for(int i=0;i<N;i++){
            cin>>a[i];
            Sum+=a[i];
            if(a[i]>Max) Max=a[i];
        }
        cout<<BinSearch(Max,Sum)<<endl;
    }
    return 0;
}
View Code

 

poj3273——经典的二分优化

标签:

原文地址:http://www.cnblogs.com/--560/p/4377422.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!