码迷,mamicode.com
首页 > 其他好文 > 详细

(博弈DP) poj 2068

时间:2015-03-30 12:43:30      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:

Nim
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 1362   Accepted: 762

Description

Let‘s play a traditional game Nim. You and I are seated across a table and we have a hundred stones on the table (we know the number of stones exactly). We play in turn and at each turn, you or I can remove on to four stones from the heap. You play first and the one who removed the last stone loses. 
In this game, you have a winning strategy. To see this, you first remove four stones and leave 96 stones. No matter how I play, I will end up with leaving 92 - 95 stones. Then you will in turn leave 91 stones for me (verify this is always possible). This way, you can always leave 5k+1 stones for me and finally I get the last stone, sigh. If we initially had 101 stones, on the other hand, I have a winning strategy and you are doomed to lose. 

Let‘s generalize the game a little bit. First, let‘s make it a team game. Each team has n players and the 2n players are seated around the table, with each player having opponents at both sides. Turn around the table so the two teams play alternately. Second, let‘s vary the maximum number of stones each player can take. That is, each player has his/her own maximum number of stones he/she can take at each turn (The minimum is always one). So the game is asymmetric and may even be unfair. 

In general, when played between two teams of experts, the outcome of a game is completely determined by the initial number of stones and the maximum number of stones each player can take at each turn. In other words, either team has a winning strategy. 

You are the head-coach of a team. In each game, the umpire shows both teams the initial number of stones and the maximum number of stones each player can take at each turn. Your team plays first. Your job is, given those numbers, to instantaneously judge whether your team has a winning strategy. 

Incidentally, there is a rumor that Captain Future and her officers of Hakodate-maru love this game, and they are killing their time playing it during their missions. You wonder where the stones are? Well, they do not have stones but do have plenty of balls in the fuel containers! 

Input

The input is a sequence of lines, followed by the last line containing a zero. Each line except the last is a sequence of integers and has the following format. 

n S M1 M2 . . . M2n 

where n is the number of players in a team, S the initial number of stones, and Mi the maximum number of stones ith player can take. 1st, 3rd, 5th, ... players are your team‘s players and 2nd, 4th, 6th, ... the opponents. Numbers are separated by a single space character. You may assume 1 <= n <= 10, 1 <= Mi <= 16, and 1 <= S < 2^13. 

Output

The output should consist of lines each containing either a one, meaning your team has a winning strategy, or a zero otherwise. 

Sample Input

1 101 4 4
1 100 4 4
3 97 8 7 6 5 4 3
0

Sample Output

0
1
1

很水。。。。dp[i][j]表示 i个人取的时候,还存在j个石子。。。记忆化搜索就好
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<cstdlib>
#include<queue>
#include<vector>
#include<stack>
using namespace std;
int n,s,num[21],dp[21][(1<<13)+100];
int dfs(int id,int remain)
{
    if(dp[id][remain]!=-1) return dp[id][remain];
    if(remain==0)
        return dp[id][remain]=1;
    dp[id][remain]=0;
    for(int i=1;i<=num[id]&&i<=remain;i++)
    {
        if(!dfs((id+1)%(2*n),remain-i))
            dp[id][remain]=1;
    }
    return dp[id][remain];
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            break;
        scanf("%d",&s);
        for(int i=0;i<2*n;i++)
            scanf("%d",&num[i]);
        memset(dp,-1,sizeof(dp));
        if(dfs(0,s))
            printf("1\n");
        else
            printf("0\n");
    }
    return 0;
}

  

(博弈DP) poj 2068

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4377439.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!