码迷,mamicode.com
首页 > 其他好文 > 详细

数据结构练习 02-线性结构1. 一元多项式求导 (25)

时间:2015-03-30 12:50:49      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:

设计函数求一元多项式的导数。(注:xn(n为整数)的一阶导数为n*xn-1。)

输入格式:以指数递降方式输入多项式非零项系数和指数(绝对值均为不超过1000的整数)。数字间以空格分隔。

输出格式:以与输入相同的格式输出导数多项式非零项的系数和指数。数字间以空格分隔,但结尾不能有多余空格。注意“零多项式”的指数和系数都是0,但是表示为“0 0”。

输入样例:

3 4 -5 2 6 1 -2 0
输出样例:
12 3 -10 1 6 0
 
#include<iostream>
#include<string>
using namespace std;
typedef struct Lnode{
    int coe;
    int index;
    struct Lnode *next;
}pol;
int main(){
    int coe,index,n=0;
    pol *head=new pol;
    pol *p=new pol,*q;
    head->next=p;
     while(cin>>coe>>index) 
    {
        
        p->coe=coe;
        p->index=index;
        n++;
        q=p;
        p= new pol;
        q->next=p;
    } 
    q->next=NULL;
    delete p;
    p=head->next;
    while(p!=NULL){
        p->coe=p->coe*p->index;
        if(p->index!=0)
            p->index=p->index-1;
        p=p->next;
    }
    p=head->next;
    while(p!=NULL){
        if(p->next!=NULL && p->index==0 && p->next->index==0){
            q=p->next;
            p->next=q->next;
            delete q;
        }
        if(p->next!=NULL &&  p->next->coe==0){
            q=p->next;
            p->next=q->next;
            delete q;
        }
        p=p->next;
    }
    p=head->next;
    while(p!=NULL){
        cout<<p->coe<<" "<<p->index;
        if(p->next!=NULL){
            cout<<" ";
        }
        p=p->next;
    }
    return 0;
}

技术分享

经过19次提交,总算是成功了。读懂题很重要啊

数据结构练习 02-线性结构1. 一元多项式求导 (25)

标签:

原文地址:http://www.cnblogs.com/Zengineer/p/4377588.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!