码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 题目1312 Red and Black(DFS)

时间:2015-03-30 14:43:01      阅读:126      评论:0      收藏:0      [点我收藏+]

标签:

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11470    Accepted Submission(s): 7136


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1240 1175 1238 1026 1239 
 
ac代码
#include<stdio.h>
#include<string.h>
char map[22][22];
int n,m,ans;
int dx[4]={0,1,0,-1};
int dy[4]={1,0,-1,0};
void dfs(int x,int y)
{
	int i;
	ans++;
	map[x][y]='#';
	for(i=0;i<4;i++)
	{
		int tx=x+dx[i];
		int ty=y+dy[i];
		if(tx>=0&&tx<n&&ty>=0&&ty<m&&map[tx][ty]=='.')
		{
			dfs(tx,ty);
		}
	}
}
int main()
{
	while(scanf("%d%d",&m,&n)!=EOF,n||m)
	{
		int i,j,x,y;
		for(i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for(j=0;j<m;j++)
			{
				if(map[i][j]=='@')
				{
					x=i;
					y=j;
				}
			}
		}
		ans=0;
		dfs(x,y);
		printf("%d\n",ans);
	}
}


HDOJ 题目1312 Red and Black(DFS)

标签:

原文地址:http://blog.csdn.net/yu_ch_sh/article/details/44750059

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!