码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 1368 DNA(模拟+贪心)

时间:2015-03-31 00:41:16      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:

DNA (Deoxyribonucleic Acid) is the molecule which contains the genetic instructions. It consists of four different nucleotides, namely Adenine, Thymine, Guanine, and Cytosine as shown in Figure 1. If we represent a nucleotide by its initial character, a DNA strand can be regarded as a long string (sequence of characters) consisting of the four characters A, T, G, and C. For example, assume we are given some part of a DNA strand which is composed of the following sequence of nucleotides:


``Thymine-Adenine-Adenine-Cytosine-Thymine-Guanine-Cytosine-Cytosine-Guanine-Adenine-Thymine"


Then we can represent the above DNA strand with the string ``TAACTGCCGAT." The biologist Prof. Ahn found that a gene X commonly exists in the DNA strands of five different kinds of animals, namely dogs, cats, horses, cows, and monkeys. He also discovered that the DNA sequences of the gene X from each animal were very alike. See Figure 2.

 

  DNA sequence of gene X
Cat: GCATATGGCTGTGCA
Dog: GCAAATGGCTGTGCA
Horse: GCTAATGGGTGTCCA
Cow: GCAAATGGCTGTGCA
Monkey: GCAAATCGGTGAGCA

 

Figure 2. DNA sequences of gene X in five animals.


Prof. Ahn thought that humans might also have the gene X and decided to search for the DNA sequence of X in human DNA. However, before searching, he should define a representative DNA sequence of gene X because its sequences are not exactly the same in the DNA of the five animals. He decided to use the Hamming distance to define the representative sequence. The Hamming distance is the number of different characters at each position from two strings of equal length. For example, assume we are given the two strings ``AGCAT" and ``GGAAT." The Hamming distance of these two strings is 2 because the 1st and the 3rd characters of the two strings are different. Using the Hamming distance, we can define a representative string for a set of multiple strings of equal length. Given a set of strings S = s1,...,sm<tex2html_verbatim_mark> of length n<tex2html_verbatim_mark> , the consensus error between a string y<tex2html_verbatim_mark> of length n<tex2html_verbatim_mark> and the set S<tex2html_verbatim_mark> is the sum of the Hamming distances between y<tex2html_verbatim_mark> and eachsi<tex2html_verbatim_mark> in S<tex2html_verbatim_mark> . If the consensus error between y<tex2html_verbatim_mark> and S<tex2html_verbatim_mark> is the minimum among all possible strings y<tex2html_verbatim_mark> of length n<tex2html_verbatim_mark> , y<tex2html_verbatim_mark> is called a consensus string ofS<tex2html_verbatim_mark> . For example, given the three strings `` AGCAT" `` AGACT" and `` GGAAT" the consensus string of the given strings is `` AGAAT" because the sum of the Hamming distances between `` AGAAT" and the three strings is 3 which is minimal. (In this case, the consensus string is unique, but in general, there can be more than one consensus string.) We use the consensus string as a representative of the DNA sequence. For the example of Figure 2 above, a consensus string of gene X is `` GCAAATGGCTGTGCA" and the consensus error is 7.

Input 

Your program is to read from standard input. The input consists of T<tex2html_verbatim_mark> test cases. The number of test cases T<tex2html_verbatim_mark> is given in the first line of the input. Each test case starts with a line containing two integers m<tex2html_verbatim_mark> and n<tex2html_verbatim_mark> which are separated by a single space. The integer m<tex2html_verbatim_mark>(4技术分享m技术分享50)<tex2html_verbatim_mark>represents the number of DNA sequences and n<tex2html_verbatim_mark>(4技术分享n技术分享1000)<tex2html_verbatim_mark> represents the length of the DNA sequences, respectively. In each of the next m<tex2html_verbatim_mark> lines, each DNA sequence is given.

Output 

Your program is to write to standard output. Print the consensus string in the first line of each case and the consensus error in the second line of each case. If there exists more than one consensus string, print the lexicographically smallest consensus string. The following shows sample input and output for three test cases.

Sample Input 

3 
5 8 
TATGATAC 
TAAGCTAC 
AAAGATCC 
TGAGATAC 
TAAGATGT 
4 10 
ACGTACGTAC 
CCGTACGTAG 
GCGTACGTAT 
TCGTACGTAA 
6 10 
ATGTTACCAT 
AAGTTACGAT 
AACAAAGCAA 
AAGTTACCTT 
AAGTTACCAA 
TACTTACCAA

Sample Output 

TAAGATAC 
7 
ACGTACGTAA 
6 
AAGTTACCAA 
12

题目大意:

  就是说,给你一个m个长度为n的字符串,然后,让你从中找出来,所谓的某个距离最小的串。

这个串就是我们说的一致串,然后,对于这个计算出来的串,计算这个串与m个串的不同的字符数。

解题思路:

  这题就是模拟带点贪心的意思了,开始的时候把m个长度为n的串放到一个m*n的二维字符型

数组中,然后呢,我们每次扫一遍这个二维数组的列,把出现最次数最多的这个字符记录下来,那

么我们所确定的ans[]的值就被确定下来了,以此类推,如果每个字符出现的次数都是相同的,那么

我们就直接出A就行了,以为题目要求ans[]串是按照字典序最小的形式输出的。。那肯定尽量让它

为A了。

  所以,总结下,归根到底,就是两次贪心,一次是按列贪心,找出出现次数最多的字符。

一类是在所有字符出现相同的情况下,赋值‘A’ ,保证字典序最小了。

代码:

 

# include<cstdio>
# include<iostream>
# include<algorithm>
# include<cstring>
# include<string>
# include<cmath>
# include<queue>
# include<stack>
# include<set>
# include<map>

using namespace std;

# define inf 999999999
# define MAX1 1000+4
# define MAX2 50+4

char s[MAX2][MAX1];
char ans[MAX1];

int num[5];// A C G T
int t,cnt;
int m,n;


void input()
{
    memset(s,0,sizeof(s));
    for ( int i = 0;i < m;i++ )
    {
        for ( int j = 0;j < n;j++ )
        {
            cin>>s[i][j];
        }
        getchar();
    }

}

int check()
{
    int flag = 0;
    for ( int i = 0;i < 4-1;i++ )
    {
        if ( num[i]-num[i+1]!=0 )
        {
            flag = 1;
            break;
        }
    }
    if ( flag )
   {
       int _max = num[0];
    int tt = 0;
    for ( int i = 0;i < 4;i++ )
    {
        if ( num[i] > _max )
        {
            _max = num[i];
            tt = i;
        }
    }

    return tt;
   }
   else
    return 0;
}

void solve()
{
    for ( int j = 0;j < n;j++ )
    {
        for ( int i = 0;i < m;i++ )
        {
            char ch = s[i][j];
            if ( ch==‘A‘ )
                num[0]++;
            else if ( ch==‘C‘ )
                num[1]++;
            else if ( ch==‘G‘ )
                num[2]++;
            else
                num[3]++;
        }
        int tag = check();
        if ( tag==0 )
            ans[j]=‘A‘;
        else if ( tag==1 )
            ans[j]=‘C‘;
        else if ( tag==2 )
            ans[j]=‘G‘;
        else
            ans[j]=‘T‘;
        memset(num,0,sizeof(num));
    }
}

void cal()
{
    cnt = 0;
    for ( int i = 0;i < m;i++ )
    {
        for ( int j = 0;j < n;j++ )
        {
            if ( s[i][j]!=ans[j] )
            {
                cnt++;
            }
        }
    }
}

void output()
{
    for ( int i = 0;i < n;i++ )
    {
        cout<<ans[i];
    }
    cout<<endl;
    cout<<cnt<<endl;
}


int main(void)
{
    cin>>t;
    while ( t-- )
    {
        cin>>m>>n;
        memset(num,0,sizeof(num));
        memset(ans,0,sizeof(ans));
        getchar();
        input();
        solve();
        cal();
        output();
    }

	return 0;
}

  

UVA 1368 DNA(模拟+贪心)

标签:

原文地址:http://www.cnblogs.com/wikioibai/p/4379527.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!